Can't clone bkbits.net bugfix or dev, but can clone bk_demo


#1

I can’t puil bugfix or dev on bkbits.
I’m getting a message about “Could not lock product”.
I tried cloning bugfix and it wouldn’t clone. But cloning bk_demo worked.
I tried yesterday and today and got the same output.

~/src$ bk clone bk://bkbits.net/bkdemo/bk_demo
Clone bk://bkbits.net/bkdemo/bk_demo
   -> file:///home/cb/src/bk/bk_demo
clone                              100% |==============================| OK
~/src$ bk clone  bk://bkbits.net/bk/bugfix b2
ERROR-Could not lock product, mutex failed.
~/src$

#2

Yeah, bkbits is messed up. I’ll try and sort it out tomorrow. Sorry about the bumps.


#3

Try it now. It was out of disk space.


#4

Yes, it is working now! Thanks.


#5

I’m seeing the error again. Not that I need the service.
I was checking to see if anything new had appeared.

~/src/bk/dev$ bk pull
Pull bk://bkbits.net/bk/dev
  -> file:///home/cb/src/bk/dev
ERROR-Could not lock product, mutex failed.

#6

Try again, freed up some space.


#7
~/src/bk/dev$ bk pull
Pull bk://bkbits.net/bk/dev
  -> file:///home/cb/src/bk/dev
Nothing to pull.

It’s working! Thanks.


#8

It’s doing it again for me today. I see there aren’t any changes to pull, but…


#9

Wayne’s kindly fixed it again and, yay, building is as easy as the instructions say. I no longer get stuck here:

make[4]: Entering directory '/home/martind/download/bk/dev/src/gui/tcltk’
Building Tcl/Tk
grep: write error: Broken pipe
make[5]: Entering directory '/home/martind/download/bk/dev/src/gui/tcltk’
Cloning TclTk repos
ssh: Could not resolve hostname nbkbits: Name or service not known
here: searching bk://bkbits.net/u/bk/dev…ok (gate)
here: searching ssh://bk@nbkbits/dev-oss…connect failure
here: searching bk://bkbits.net//home/bk/dev-oss…repo gone
here: searching bk://bkbits.net/bk/dev…ok (gate)
here: No other sources for ./src/gui/tcltk/bwidget known
make[5]: [Makefile:161: populate] Error 1 (ignored)
make[5]: Leaving directory '/home/martind/download/bk/dev/src/gui/tcltk’
make[5]: Entering directory ‘/home/martind/download/bk/dev/src/gui/tcltk’
/bin/sh: 1: cd: can’t cd to tcl
make[5]: [Makefile:165: tcl/unix/configure] Error 2 (ignored)
Configuring Tcl
/bin/sh: 1: cd: can’t cd to tcl/unix
/bin/sh: 2: ./configure: not found