This post is just a heads-up on a change that will probably be included in the next release. It is a documentation-only update. The commands ‘bk get file’ and ‘bk co file’ are aliases and checkout the latest version of a file. In the existing BitKeeper, only ‘co’ is documented, but in the code and in most of our writing this operation is referred to as ‘get’. So we are changing the documentation to reflect that and document this command as ‘bk get’.
Similarly, ‘bk delta’ and ‘bk ci’ will save local modifications to a file and create a new delta is the SCCS history. Delta is the verb we use and so that is what will be documented.
Just noting that change here in case someone has strong opinions about the change.
No objection here. Fwiw, we seem to have a few of each variant. Good to know there’s no difference, though bk help pretty much told me that already. (Somewhat contra Wayne’s OP, “bk help get” worked for me but that’s bk-7.1 20160219220356, not the CE.) The one wrinkle I’ve been bitten by in this area is the difference between bk checkout and bk co, which I’m pleased to see is documented. I wonder which one “get” will do. I doubt I mind, as we mainly use bk get with -p, but having it documented would be helpful.
Yeah, get and co are exactly identical and help on both commands have always pulled up the same manpage. I am switching that manpage to say ‘get’ instead of co, but the code stays the same. Same with delta and ci.
I think I should probably update the new manpage for ‘bk get’ to explicitly say that ‘bk co’ is an alias in addition to having ‘bk help co’ redirect to the get manpage.