X-Windows related issue


#1

Hello,

I am entirely new to Bitkeeper and have also never worked with X-Windows. I’m seeing the following error on the former:

$ bk helptool ~
Cannot find a display to use (set $DISPLAY?).

Thinking that this would not be sufficient for getting me around the problem, I went ahead and tried:

$ DISPLAY=’:0.0’; export DISPLAY

But got the following:

$ bk helptool ~
Application initialization failed: couldn’t connect to display ":0.0"
Error in startup script: invalid command name “wm"
while executing
"wm withdraw .”
(file “/usr/lib/bitkeeper/gui/lib/helptool” line 1)

Is it possible to simply set bitkeeper to not use X-Windows? The host in question is running a very old NFSROOT based setup. X-Windows may not even be running on it and I am leery of trying to modify the setup to bring X up.

-Anthony


#2

Yep, for each tool there is a command line version like (well sort of)

helptool -> help
revtool -> log
difftool -> diffs
csettool -> changes


#3

Thanks, Larry. I’ll pass this information on.